Call Recording Reliability

Incident Report for ClarifyGo

Resolved

Update on Call Recording Reliability
We want to provide an update regarding an ongoing issue that is affecting the reliability of Microsoft Teams call recordings for some customers.

What’s happening

Some calls may have incomplete or missing recordings due to a combination of factors. On our side, our message-handling system is occasionally not processing some incoming messages. This can result in gaps when events from Teams are not captured in our system. Additionally, there is an ongoing issue on the Microsoft side that is causing participant updates to occasionally not be sent to us at all. This contributes significantly to the randomness of the problem—some calls may be fully recorded while others may have partial or missing data. Because of this, the impact is inconsistent, and only some customers may be affected in some calls.

We are addressing the issues as follows :-
Completed : We have documented the Microsoft Teams participant issue and passed it across to Microsoft for further investigation.
Short term (this week): We are implementing a partial rollback to reduce the number of dropped messages and to alleviate some of the immediate issues.
Middle term (next 1-2 weeks): We’ve updated our message broker which improves how our message queues are handled, reducing the likelihood of any message loss. This will be released following testing and QA.
Long term (next 1-2 months) : We are deploying our new large scale version of ClarifyGo using Kubernetes. This does not have any message broking issues and is infinitely scalable. All customers will be automatically upgraded to the new platform.

We recognize the inconvenience this causes and are treating this as a top priority. Our engineering team is fully focused on resolving this issue and ensuring maximum stability and reliability of the ClarifyGo platform.
We appreciate your patience as we work through these challenges and will provide updates as progress is made.

Data Recovery

Unfortunately, any recordings that were lost due to this issue are not recoverable.
Posted Dec 10, 2025 - 11:00 GMT